2012-02-04

Last edit

Summary: If you’re an Emacs dev and had trouble updating your sources, you need to follow Eli’s advice

Added:

> More strange errors and I discover I should [http://permalink.gmane.org/gmane.emacs.bugs/50675 run ./autogen.sh].
> {{{
> Checking for automake (need at least version 1.11)...
> too old
> }}}
> I think this machine no longer qualifies as an Emacs dev machine!


If you’re an Emacs dev and had trouble updating your sources, you need to follow Eli’s advice:

Nothing should be required, except editing your
.bzr/branch/branch.conf as I described:

 Replace

  sftp://USERNAME <at> bzr.savannah.gnu.org/srv/bzr/emacs/trunk/

 with

  bzr+ssh://USERNAME <at> bzr.savannah.gnu.org/emacs/trunk/

Worked for me! Except now I realized “Autoconf version 2.65 or higher is required”. :) More strange errors and I discover I should run ./autogen.sh.

Checking for automake (need at least version 1.11)...
too old

I think this machine no longer qualifies as an Emacs dev machine!