EnhancedRubyMode

Enhanced Ruby Mode can be used as a RubyMode for replacement for ruby >= 1.9.2: https://github.com/zenspider/enhanced-ruby-mode